ELMS Learning Network (ELMSLN) is an open source educational technology platform for building and sustaining innovation in course technologies. It accomplishes this by taking a Suite of Tools approach to learning design, allowing several systems to make up the different aspects of a course learning environment. Each course effectively forms a network of technologies (hence the name) which can then be better tailored to each individual course's needs.

Learn more about ELMSLN @ elmsln.org

Version PHP Includes Status
0.9.0 5.4+ & 7.x Drupal 7.x Build Status OpenCollective OpenCollective

Play quickly

Vagrant is the fastest way to get up and running quickly. See the Vagrant installation documentation on how to get up and running now!


If you notice an issue or have a question please file it in our issue queue.


See the Docs for questions and documentation either on our docs site or API site.

Code of Conduct

See https://github.com/elmsln/elmsln/blob/master/CODE_OF_CONDUCT.md for our ELMS:LN code of conduct.

How can I get more involved?

There are many ways you can get involved in helping build ELMSLN; not all of which are technical in nature. The easiest way is to click the issues button in this repository. Submit feedback, help, questions, pedagogy, ideas, fan-art anything that helps us further our mission! All help and outreach is welcome and responded to.

Test, ask, jump in on the issue queues on github, drupal.org, twitter, email, phone, meet ups, drupalcamps, edtech events, our offices, coffee shops, or anywhere else that you can find pieces that will help build upon this work. We are here to make the future awesome together.


Support us with a monthly donation and help us continue our activities. [Become a backer]


Become a sponsor and get your logo on our README on Github with a link to your site. [Become a sponsor]


ELMSLN is a collection of many, many projects, all individually licensed, all open source. The myriad of License files is why this section is added to avoid confusion. If you have a licensing issue / question please raise it in the issue queue.

  • The ELMS:LN top level repository is GPLv3, though most of the underlying code pulled in is not GPLv3. V3 enabled the greatest level of compatibility with our downstream repositories
  • Drupal core and contributed modules / themes are GPLv2 due to licensing requirements of the drupal.org community.
  • For other included libraries see their respective LICENSE.txt file included local to those libraries.